ModSecurity Breach

ModSecurity Blog

« OSCOM Talks Presentations Uploaded | Main | ModSecurity for Java Milestone 3 now available »

mod_security and the PHPBB worm (Santy.A)

I have been asked to design a mod_security rule to protect sites from the recent PHPBB worm. Now, I don't have access to PHPBB (vulnerable or not) but looking at the worm log entries I have found online it should be simple:

SecFilterSelective ARG_highlight %27

This should prevent someone from trying to sneak an URL-encoded apostrophe in through the vulnerable variable "highlight". As I said, don't take my word for it. If you have a vulnerable installation use the exploit after installing the rule to see if it works. Please let me know whether the rule works or not. And don't forget to fix the real problem by upgrading your version of PHPBB. Update: As Ralph Germershausen points out, while you are fixing PHPBB also make sure you are using the latest PHP version (4.3.10 if you are still with the 4.x branch or 5.0.3 if you are with the 5.x branch). This is to take care of the recently announced vulnerabilities.

Calendar

November 2010
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30

Feeds

Atom Feed

Search

Categories

Recent Entries

Archives